summaryrefslogtreecommitdiffstats
path: root/wgpu/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'wgpu/Cargo.toml')
-rw-r--r--wgpu/Cargo.toml42
1 files changed, 27 insertions, 15 deletions
diff --git a/wgpu/Cargo.toml b/wgpu/Cargo.toml
index 17dfb4a3..5f4699a8 100644
--- a/wgpu/Cargo.toml
+++ b/wgpu/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "iced_wgpu"
-version = "0.1.0"
+version = "0.3.0"
authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
edition = "2018"
description = "A wgpu renderer for Iced"
@@ -9,29 +9,41 @@ repository = "https://github.com/hecrj/iced"
[features]
svg = ["resvg"]
-canvas = ["lyon"]
+canvas = ["iced_graphics/canvas"]
+qr_code = ["iced_graphics/qr_code"]
+default_system_font = ["iced_graphics/font-source"]
[dependencies]
-iced_native = { version = "0.1.0", path = "../native" }
-iced_style = { version = "0.1.0-alpha", path = "../style" }
-wgpu = "0.4"
-wgpu_glyph = "0.7"
-glyph_brush = "0.6"
+wgpu = "0.6"
+wgpu_glyph = "0.10"
+glyph_brush = "0.7"
raw-window-handle = "0.3"
-glam = "0.8"
-font-kit = "0.5"
log = "0.4"
-guillotiere = "0.4"
+guillotiere = "0.6"
+futures = "0.3"
+
+[dependencies.bytemuck]
+version = "1.4"
+features = ["derive"]
+
+[dependencies.iced_native]
+version = "0.3"
+path = "../native"
+
+[dependencies.iced_graphics]
+version = "0.1"
+path = "../graphics"
+features = ["font-fallback", "font-icons"]
[dependencies.image]
-version = "0.22"
+version = "0.23"
optional = true
[dependencies.resvg]
-version = "0.8"
+version = "0.9"
features = ["raqote-backend"]
optional = true
-[dependencies.lyon]
-version = "0.15"
-optional = true
+[package.metadata.docs.rs]
+rustdoc-args = ["--cfg", "docsrs"]
+all-features = true