summaryrefslogtreecommitdiffstats
path: root/wgpu/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'wgpu/Cargo.toml')
-rw-r--r--wgpu/Cargo.toml29
1 files changed, 15 insertions, 14 deletions
diff --git a/wgpu/Cargo.toml b/wgpu/Cargo.toml
index 0794b970..db3104c4 100644
--- a/wgpu/Cargo.toml
+++ b/wgpu/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "iced_wgpu"
-version = "0.2.1"
+version = "0.2.2"
authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
edition = "2018"
description = "A wgpu renderer for Iced"
@@ -9,40 +9,41 @@ repository = "https://github.com/hecrj/iced"
[features]
svg = ["resvg"]
-canvas = ["lyon"]
+canvas = ["iced_graphics/canvas"]
+default_system_font = ["iced_graphics/font-source"]
[dependencies]
wgpu = "0.5"
-wgpu_glyph = "0.8"
+wgpu_glyph = "0.9"
+glyph_brush = "0.7"
zerocopy = "0.3"
-glyph_brush = "0.6"
+bytemuck = "1.2"
raw-window-handle = "0.3"
glam = "0.8"
-font-kit = "0.4"
log = "0.4"
-guillotiere = "0.4"
+guillotiere = "0.5"
+# Pin `gfx-memory` until https://github.com/gfx-rs/wgpu-rs/issues/261 is
+# resolved
+gfx-memory = "=0.1.1"
[dependencies.iced_native]
version = "0.2"
path = "../native"
-[dependencies.iced_style]
+[dependencies.iced_graphics]
version = "0.1"
-path = "../style"
+path = "../graphics"
+features = ["font-fallback", "font-icons"]
[dependencies.image]
-version = "0.22"
+version = "0.23"
optional = true
[dependencies.resvg]
-version = "0.8"
+version = "0.9"
features = ["raqote-backend"]
optional = true
-[dependencies.lyon]
-version = "0.15"
-optional = true
-
[package.metadata.docs.rs]
rustdoc-args = ["--cfg", "docsrs"]
all-features = true