summaryrefslogtreecommitdiffstats
path: root/wgpu/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--wgpu/Cargo.toml28
1 files changed, 13 insertions, 15 deletions
diff --git a/wgpu/Cargo.toml b/wgpu/Cargo.toml
index ca89cc26..8dc4b990 100644
--- a/wgpu/Cargo.toml
+++ b/wgpu/Cargo.toml
@@ -8,25 +8,24 @@ license = "MIT AND OFL-1.1"
repository = "https://github.com/iced-rs/iced"
[features]
-bmp = ["iced_graphics/bmp"]
-canvas = ["iced_graphics/canvas"]
-dds = ["iced_graphics/dds"]
-default_system_font = ["iced_graphics/font-source"]
-farbfeld = ["iced_graphics/farbfeld"]
-gif = ["iced_graphics/gif"]
-hdr = ["iced_graphics/hdr"]
-ico = ["iced_graphics/ico"]
+svg = ["iced_graphics/svg"]
image = ["iced_graphics/image"]
+png = ["iced_graphics/png"]
jpeg = ["iced_graphics/jpeg"]
jpeg_rayon = ["iced_graphics/jpeg_rayon"]
-png = ["iced_graphics/png"]
+gif = ["iced_graphics/gif"]
+webp = ["iced_graphics/webp"]
pnm = ["iced_graphics/pnm"]
+ico = ["iced_graphics/ico"]
+bmp = ["iced_graphics/bmp"]
+hdr = ["iced_graphics/hdr"]
+dds = ["iced_graphics/dds"]
+farbfeld = ["iced_graphics/farbfeld"]
+canvas = ["iced_graphics/canvas"]
qr_code = ["iced_graphics/qr_code"]
+default_system_font = ["iced_graphics/font-source"]
spirv = ["wgpu/spirv"]
-svg = ["iced_graphics/svg"]
-trace = ["iced_profiling"]
webgl = ["wgpu/webgl"]
-webp = ["iced_graphics/webp"]
[dependencies]
wgpu = "0.14"
@@ -51,9 +50,8 @@ version = "0.5"
path = "../graphics"
features = ["font-fallback", "font-icons"]
-[dependencies.iced_profiling]
-version = "0.1.0"
-path = "../profiling"
+[dependencies.tracing]
+version = "0.1.6"
optional = true
[dependencies.encase]