summaryrefslogtreecommitdiffstats
path: root/web/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'web/Cargo.toml')
-rw-r--r--web/Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/web/Cargo.toml b/web/Cargo.toml
new file mode 100644
index 00000000..d5a987b0
--- /dev/null
+++ b/web/Cargo.toml
@@ -0,0 +1,33 @@
+[package]
+name = "iced_web"
+version = "0.1.0-alpha"
+authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
+edition = "2018"
+description = "A web backend for Iced"
+license = "MIT"
+repository = "https://github.com/hecrj/iced"
+documentation = "https://docs.rs/iced_web"
+readme = "README.md"
+keywords = ["gui", "ui", "web", "interface", "widgets"]
+categories = ["web-programming"]
+
+[badges]
+maintenance = { status = "actively-developed" }
+
+[dependencies]
+iced_core = { version = "0.1.0-alpha", path = "../core" }
+dodrio = "0.1.0"
+futures-preview = "=0.3.0-alpha.18"
+wasm-bindgen = "0.2.50"
+
+[dependencies.web-sys]
+version = "0.3.27"
+features = [
+ "console",
+ "Document",
+ "HtmlElement",
+ "HtmlInputElement",
+ "Event",
+ "EventTarget",
+ "InputEvent",
+]