summaryrefslogtreecommitdiffstats
path: root/tiny_skia/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tiny_skia/Cargo.toml')
-rw-r--r--tiny_skia/Cargo.toml48
1 files changed, 21 insertions, 27 deletions
diff --git a/tiny_skia/Cargo.toml b/tiny_skia/Cargo.toml
index d9276ea5..df4c6143 100644
--- a/tiny_skia/Cargo.toml
+++ b/tiny_skia/Cargo.toml
@@ -1,7 +1,14 @@
[package]
name = "iced_tiny_skia"
-version = "0.1.0"
-edition = "2021"
+description = "A software renderer for iced on top of tiny-skia"
+version.workspace = true
+edition.workspace = true
+authors.workspace = true
+license.workspace = true
+repository.workspace = true
+homepage.workspace = true
+categories.workspace = true
+keywords.workspace = true
[features]
image = ["iced_graphics/image"]
@@ -9,30 +16,17 @@ svg = ["resvg"]
geometry = ["iced_graphics/geometry"]
[dependencies]
-raw-window-handle = "0.5"
-softbuffer = "0.2"
-tiny-skia = "0.10"
-bytemuck = "1"
-rustc-hash = "1.1"
-kurbo = "0.9"
-log = "0.4"
+iced_graphics.workspace = true
-[dependencies.iced_graphics]
-version = "0.8"
-path = "../graphics"
+bytemuck.workspace = true
+cosmic-text.workspace = true
+kurbo.workspace = true
+log.workspace = true
+raw-window-handle.workspace = true
+rustc-hash.workspace = true
+softbuffer.workspace = true
+tiny-skia.workspace = true
+xxhash-rust.workspace = true
-[dependencies.cosmic-text]
-git = "https://github.com/hecrj/cosmic-text.git"
-rev = "c3cd24dc972bb8fd55d016c81ac9fa637e0a4ada"
-
-[dependencies.twox-hash]
-version = "1.6"
-default-features = false
-
-[target.'cfg(not(target_arch = "wasm32"))'.dependencies.twox-hash]
-version = "1.6.1"
-features = ["std"]
-
-[dependencies.resvg]
-version = "0.35"
-optional = true
+resvg.workspace = true
+resvg.optional = true