summaryrefslogtreecommitdiffstats
path: root/renderer/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'renderer/Cargo.toml')
-rw-r--r--renderer/Cargo.toml39
1 files changed, 16 insertions, 23 deletions
diff --git a/renderer/Cargo.toml b/renderer/Cargo.toml
index 2c88cf31..56e17209 100644
--- a/renderer/Cargo.toml
+++ b/renderer/Cargo.toml
@@ -1,14 +1,14 @@
[package]
name = "iced_renderer"
-version = "0.1.0"
-authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
-edition = "2021"
-description = "The official renderer for Iced"
-license = "MIT"
-repository = "https://github.com/iced-rs/iced"
-documentation = "https://docs.rs/iced_renderer"
-keywords = ["gui", "ui", "graphics", "interface", "widgets"]
-categories = ["gui"]
+description = "The official renderer for iced"
+version.workspace = true
+edition.workspace = true
+authors.workspace = true
+license.workspace = true
+repository.workspace = true
+homepage.workspace = true
+categories.workspace = true
+keywords.workspace = true
[features]
wgpu = ["iced_wgpu"]
@@ -20,19 +20,12 @@ web-colors = ["iced_wgpu?/web-colors"]
webgl = ["iced_wgpu?/webgl"]
[dependencies]
-raw-window-handle = "0.5"
-thiserror = "1"
-log = "0.4"
+iced_graphics.workspace = true
+iced_tiny_skia.workspace = true
-[dependencies.iced_graphics]
-version = "0.9"
-path = "../graphics"
+iced_wgpu.workspace = true
+iced_wgpu.optional = true
-[dependencies.iced_tiny_skia]
-version = "0.1"
-path = "../tiny_skia"
-
-[dependencies.iced_wgpu]
-version = "0.11"
-path = "../wgpu"
-optional = true
+log.workspace = true
+raw-window-handle.workspace = true
+thiserror.workspace = true