summaryrefslogtreecommitdiffstats
path: root/renderer/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'renderer/Cargo.toml')
-rw-r--r--renderer/Cargo.toml10
1 files changed, 8 insertions, 2 deletions
diff --git a/renderer/Cargo.toml b/renderer/Cargo.toml
index 1f21f06b..429b55c2 100644
--- a/renderer/Cargo.toml
+++ b/renderer/Cargo.toml
@@ -6,12 +6,13 @@ edition = "2021"
[features]
image = ["iced_wgpu/image", "iced_tiny_skia/image"]
svg = ["iced_wgpu/svg", "iced_tiny_skia/svg"]
-canvas = ["iced_graphics/canvas"]
-qr_code = ["iced_graphics/qr_code"]
+canvas = ["iced_wgpu/canvas", "iced_tiny_skia/canvas"]
+qr_code = ["canvas", "qrcode"]
tracing = ["iced_wgpu/tracing"]
[dependencies]
raw-window-handle = "0.5"
+thiserror = "1"
[dependencies.iced_native]
version = "0.9"
@@ -30,3 +31,8 @@ iced_wgpu = { version = "0.9", path = "../wgpu" }
[target.'cfg(target_arch = "wasm32")'.dependencies]
iced_wgpu = { version = "0.9", path = "../wgpu", features = ["webgl"] }
+
+[dependencies.qrcode]
+version = "0.12"
+optional = true
+default-features = false