summaryrefslogtreecommitdiffstats
path: root/renderer/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'renderer/Cargo.toml')
-rw-r--r--renderer/Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/renderer/Cargo.toml b/renderer/Cargo.toml
new file mode 100644
index 00000000..2a179f3a
--- /dev/null
+++ b/renderer/Cargo.toml
@@ -0,0 +1,26 @@
+[package]
+name = "iced_renderer"
+version = "0.1.0"
+edition = "2021"
+
+[features]
+image = ["iced_wgpu/image"]
+svg = ["iced_wgpu/svg"]
+tracing = ["iced_wgpu/tracing"]
+
+[dependencies]
+raw-window-handle = "0.5"
+
+[dependencies.iced_native]
+version = "0.9"
+path = "../native"
+
+[dependencies.iced_graphics]
+version = "0.7"
+path = "../graphics"
+
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
+iced_wgpu = { version = "0.9", path = "../wgpu" }
+
+[target.'cfg(target_arch = "wasm32")'.dependencies]
+iced_wgpu = { version = "0.9", path = "../wgpu", features = ["webgl"] }