summaryrefslogtreecommitdiffstats
path: root/graphics/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/Cargo.toml')
-rw-r--r--graphics/Cargo.toml75
1 files changed, 36 insertions, 39 deletions
diff --git a/graphics/Cargo.toml b/graphics/Cargo.toml
index 15d26346..6741d7cf 100644
--- a/graphics/Cargo.toml
+++ b/graphics/Cargo.toml
@@ -1,14 +1,18 @@
[package]
name = "iced_graphics"
-version = "0.8.0"
-authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
-edition = "2021"
-description = "A bunch of backend-agnostic types that can be leveraged to build a renderer for Iced"
-license = "MIT"
-repository = "https://github.com/iced-rs/iced"
-documentation = "https://docs.rs/iced_graphics"
-keywords = ["gui", "ui", "graphics", "interface", "widgets"]
-categories = ["gui"]
+description = "A bunch of backend-agnostic types that can be leveraged to build a renderer for iced"
+version.workspace = true
+edition.workspace = true
+authors.workspace = true
+license.workspace = true
+repository.workspace = true
+homepage.workspace = true
+categories.workspace = true
+keywords.workspace = true
+
+[package.metadata.docs.rs]
+rustdoc-args = ["--cfg", "docsrs"]
+all-features = true
[features]
geometry = ["lyon_path"]
@@ -16,33 +20,26 @@ image = ["dep:image", "kamadak-exif"]
web-colors = []
[dependencies]
-glam = "0.24"
-half = "2.2.1"
-log = "0.4"
-raw-window-handle = "0.5"
-thiserror = "1.0"
-bitflags = "1.2"
-
-[dependencies.bytemuck]
-version = "1.4"
-features = ["derive"]
-
-[dependencies.iced_core]
-version = "0.9"
-path = "../core"
-
-[dependencies.image]
-version = "0.24"
-optional = true
-
-[dependencies.kamadak-exif]
-version = "0.5"
-optional = true
-
-[dependencies.lyon_path]
-version = "1"
-optional = true
-
-[package.metadata.docs.rs]
-rustdoc-args = ["--cfg", "docsrs"]
-all-features = true
+iced_core.workspace = true
+
+bitflags.workspace = true
+bytemuck.workspace = true
+cosmic-text.workspace = true
+glam.workspace = true
+half.workspace = true
+log.workspace = true
+once_cell.workspace = true
+raw-window-handle.workspace = true
+rustc-hash.workspace = true
+thiserror.workspace = true
+unicode-segmentation.workspace = true
+xxhash-rust.workspace = true
+
+image.workspace = true
+image.optional = true
+
+kamadak-exif.workspace = true
+kamadak-exif.optional = true
+
+lyon_path.workspace = true
+lyon_path.optional = true