summaryrefslogtreecommitdiffstats
path: root/futures/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'futures/Cargo.toml')
-rw-r--r--futures/Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/futures/Cargo.toml b/futures/Cargo.toml
index 91860e1e..483e60cb 100644
--- a/futures/Cargo.toml
+++ b/futures/Cargo.toml
@@ -19,12 +19,12 @@ log = "0.4"
[dependencies.futures]
version = "0.3"
-[dependencies.tokio]
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies.tokio]
version = "0.2"
optional = true
-features = ["rt-core"]
+features = ["rt-core", "rt-threaded"]
-[dependencies.async-std]
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies.async-std]
version = "1.0"
optional = true