summaryrefslogtreecommitdiffstats
path: root/futures/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'futures/Cargo.toml')
-rw-r--r--futures/Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/futures/Cargo.toml b/futures/Cargo.toml
index 078c96aa..7854dbb0 100644
--- a/futures/Cargo.toml
+++ b/futures/Cargo.toml
@@ -19,6 +19,12 @@ log = "0.4"
[dependencies.futures]
version = "0.3"
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies.tokio_old]
+package = "tokio"
+version = "0.2"
+optional = true
+features = ["rt-core", "rt-threaded", "time", "stream"]
+
[target.'cfg(not(target_arch = "wasm32"))'.dependencies.tokio]
version = "0.3"
optional = true