summaryrefslogtreecommitdiffstats
path: root/futures/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'futures/Cargo.toml')
-rw-r--r--futures/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/futures/Cargo.toml b/futures/Cargo.toml
new file mode 100644
index 00000000..91860e1e
--- /dev/null
+++ b/futures/Cargo.toml
@@ -0,0 +1,32 @@
+[package]
+name = "iced_futures"
+version = "0.1.0-alpha"
+authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
+edition = "2018"
+description = "Commands, subscriptions, and runtimes for Iced"
+license = "MIT"
+repository = "https://github.com/hecrj/iced"
+documentation = "https://docs.rs/iced_futures"
+keywords = ["gui", "ui", "graphics", "interface", "futures"]
+categories = ["gui"]
+
+[features]
+thread-pool = ["futures/thread-pool"]
+
+[dependencies]
+log = "0.4"
+
+[dependencies.futures]
+version = "0.3"
+
+[dependencies.tokio]
+version = "0.2"
+optional = true
+features = ["rt-core"]
+
+[dependencies.async-std]
+version = "1.0"
+optional = true
+
+[target.'cfg(target_arch = "wasm32")'.dependencies]
+wasm-bindgen-futures = "0.4"