summaryrefslogtreecommitdiffstats
path: root/examples/todos/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--examples/todos/Cargo.toml11
1 files changed, 8 insertions, 3 deletions
diff --git a/examples/todos/Cargo.toml b/examples/todos/Cargo.toml
index 21acd5d6..f945cde5 100644
--- a/examples/todos/Cargo.toml
+++ b/examples/todos/Cargo.toml
@@ -6,13 +6,18 @@ edition = "2018"
publish = false
[dependencies]
-iced = { path = "../.." }
-iced_futures = { path = "../../futures", features = ["async-std"] }
-async-std = "1.0"
+iced = { path = "../..", features = ["async-std"] }
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
+
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
+async-std = "1.0"
directories = "2.0"
+[target.'cfg(target_arch = "wasm32")'.dependencies]
+web-sys = { version = "0.3", features = ["Window", "Storage"] }
+wasm-timer = "0.2"
+
[package.metadata.deb]
assets = [
["target/release/todos", "usr/bin/iced-todos", "755"],