summaryrefslogtreecommitdiffstats
path: root/examples/integration/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'examples/integration/Cargo.toml')
-rw-r--r--examples/integration/Cargo.toml9
1 files changed, 2 insertions, 7 deletions
diff --git a/examples/integration/Cargo.toml b/examples/integration/Cargo.toml
index 4c55daa7..032cc75e 100644
--- a/examples/integration/Cargo.toml
+++ b/examples/integration/Cargo.toml
@@ -13,13 +13,8 @@ iced_widget.workspace = true
tracing-subscriber = "0.3"
[target.'cfg(target_arch = "wasm32")'.dependencies]
-console_error_panic_hook = "0.1.7"
-console_log = "0.2.0"
+console_error_panic_hook = "0.1"
+console_log = "1.0"
log.workspace = true
wasm-bindgen = "0.2"
web-sys = { version = "0.3", features = ["Element", "HtmlCanvasElement", "Window", "Document"] }
-
-# This dependency a little bit quirky, it is deep in the tree and without `js` feature it
-# refuses to work with `wasm32-unknown-unknown target`. Unfortunately, we need this patch
-# to make it work
-getrandom = { version = "0.2", features = ["js"] }