summaryrefslogtreecommitdiffstats
path: root/examples/integration/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'examples/integration/Cargo.toml')
-rw-r--r--examples/integration/Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/examples/integration/Cargo.toml b/examples/integration/Cargo.toml
new file mode 100644
index 00000000..200306aa
--- /dev/null
+++ b/examples/integration/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "integration"
+version = "0.1.0"
+authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
+edition = "2021"
+publish = false
+
+[dependencies]
+iced_winit = { path = "../../winit" }
+iced_wgpu = { path = "../../wgpu", features = ["webgl"] }
+env_logger = "0.8"
+
+[target.'cfg(target_arch = "wasm32")'.dependencies]
+console_error_panic_hook = "0.1.7"
+console_log = "0.2.0"
+log = "0.4"
+wasm-bindgen = "0.2"
+web-sys = { version = "0.3", features = ["Element", "HtmlCanvasElement", "Window", "Document"] }
+# This dependency a little bit quirky, it is deep in the tree and without `js` feature it
+# refuses to work with `wasm32-unknown-unknown target`. Unfortunately, we need this patch
+# to make it work
+getrandom = { version = "0.2", features = ["js"] }