summaryrefslogtreecommitdiffstats
path: root/core/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'core/Cargo.toml')
-rw-r--r--core/Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/core/Cargo.toml b/core/Cargo.toml
index c273fcb4..29a95ad7 100644
--- a/core/Cargo.toml
+++ b/core/Cargo.toml
@@ -10,6 +10,9 @@ homepage.workspace = true
categories.workspace = true
keywords.workspace = true
+[features]
+auto-detect-theme = ["dep:dark-light"]
+
[dependencies]
bitflags.workspace = true
glam.workspace = true
@@ -22,6 +25,9 @@ thiserror.workspace = true
web-time.workspace = true
xxhash-rust.workspace = true
+dark-light.workspace = true
+dark-light.optional = true
+
[target.'cfg(windows)'.dependencies]
raw-window-handle.workspace = true