summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 9 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7c222fbb..aa4bbacd 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -44,6 +44,8 @@ async-std = ["iced_futures/async-std"]
smol = ["iced_futures/smol"]
# Enables advanced color conversion via `palette`
palette = ["iced_core/palette"]
+# Enables pure, virtual widgets in the `pure` module
+pure = ["iced_pure"]
[badges]
maintenance = { status = "actively-developed" }
@@ -57,6 +59,7 @@ members = [
"glutin",
"lazy",
"native",
+ "pure",
"style",
"wgpu",
"winit",
@@ -87,6 +90,11 @@ members = [
"examples/tooltip",
"examples/tour",
"examples/url_handler",
+ "examples/pure/component",
+ "examples/pure/counter",
+ "examples/pure/pick_list",
+ "examples/pure/todos",
+ "examples/pure/tour",
"examples/websocket",
]
@@ -96,6 +104,7 @@ iced_futures = { version = "0.3", path = "futures" }
iced_winit = { version = "0.3", path = "winit" }
iced_glutin = { version = "0.2", path = "glutin", optional = true }
iced_glow = { version = "0.2", path = "glow", optional = true }
+iced_pure = { version = "0.1", path = "pure", optional = true }
thiserror = "1.0"
[target.'cfg(not(target_arch = "wasm32"))'.dependencies]