summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml51
1 files changed, 9 insertions, 42 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d0243dfd..9c45b2f5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "iced"
-version = "0.5.2"
+version = "0.6.0"
authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
edition = "2021"
description = "A cross-platform GUI library inspired by Elm"
@@ -55,50 +55,17 @@ members = [
"style",
"wgpu",
"winit",
- "examples/arc",
- "examples/bezier_tool",
- "examples/clock",
- "examples/color_palette",
- "examples/component",
- "examples/counter",
- "examples/custom_widget",
- "examples/download_progress",
- "examples/events",
- "examples/exit",
- "examples/game_of_life",
- "examples/geometry",
- "examples/integration_opengl",
- "examples/integration_wgpu",
- "examples/lazy",
- "examples/modern_art",
- "examples/multitouch",
- "examples/pane_grid",
- "examples/pick_list",
- "examples/pokedex",
- "examples/progress_bar",
- "examples/qr_code",
- "examples/scrollable",
- "examples/sierpinski_triangle",
- "examples/solar_system",
- "examples/stopwatch",
- "examples/styling",
- "examples/svg",
- "examples/system_information",
- "examples/todos",
- "examples/tooltip",
- "examples/tour",
- "examples/url_handler",
- "examples/websocket",
+ "examples/*",
]
[dependencies]
iced_core = { version = "0.6", path = "core" }
iced_futures = { version = "0.5", path = "futures" }
-iced_native = { version = "0.6", path = "native" }
-iced_graphics = { version = "0.4", path = "graphics" }
-iced_winit = { version = "0.5", path = "winit", features = ["application"] }
-iced_glutin = { version = "0.4", path = "glutin", optional = true }
-iced_glow = { version = "0.4", path = "glow", optional = true }
+iced_native = { version = "0.7", path = "native" }
+iced_graphics = { version = "0.5", path = "graphics" }
+iced_winit = { version = "0.6", path = "winit", features = ["application"] }
+iced_glutin = { version = "0.5", path = "glutin", optional = true }
+iced_glow = { version = "0.5", path = "glow", optional = true }
thiserror = "1.0"
[dependencies.image_rs]
@@ -107,10 +74,10 @@ package = "image"
optional = true
[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
-iced_wgpu = { version = "0.6", path = "wgpu", optional = true }
+iced_wgpu = { version = "0.7", path = "wgpu", optional = true }
[target.'cfg(target_arch = "wasm32")'.dependencies]
-iced_wgpu = { version = "0.6", path = "wgpu", features = ["webgl"], optional = true }
+iced_wgpu = { version = "0.7", path = "wgpu", features = ["webgl"], optional = true }
[package.metadata.docs.rs]
rustdoc-args = ["--cfg", "docsrs"]