summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4d6531e1..364f1b5c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -172,11 +172,12 @@ raw-window-handle = "0.6"
resvg = "0.42"
rustc-hash = "2.0"
sha2 = "0.10"
+sipper = "0.1"
smol = "1.0"
smol_str = "0.2"
softbuffer = "0.4"
syntect = "5.1"
-sysinfo = "0.30"
+sysinfo = "0.33"
thiserror = "1.0"
tiny-skia = "0.11"
tokio = "1.0"
@@ -200,6 +201,7 @@ unused_results = "deny"
[workspace.lints.clippy]
type-complexity = "allow"
+map-entry = "allow"
semicolon_if_nothing_returned = "deny"
trivially-copy-pass-by-ref = "deny"
default_trait_access = "deny"