summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9c45b2f5..2cedb1b6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -39,6 +39,14 @@ smol = ["iced_futures/smol"]
palette = ["iced_core/palette"]
# Enables querying system information
system = ["iced_winit/system"]
+# Enables tracing with Chrome
+trace_chrome = [
+ "iced_winit/trace",
+ "iced_wgpu?/trace",
+ "iced_glow?/trace",
+ "iced_glutin?/trace",
+ "iced_profiling/tracing-chrome"
+]
[badges]
maintenance = { status = "actively-developed" }
@@ -51,6 +59,7 @@ members = [
"glow",
"glutin",
"lazy",
+ "profiling",
"native",
"style",
"wgpu",
@@ -66,6 +75,7 @@ iced_graphics = { version = "0.5", path = "graphics" }
iced_winit = { version = "0.6", path = "winit", features = ["application"] }
iced_glutin = { version = "0.5", path = "glutin", optional = true }
iced_glow = { version = "0.5", path = "glow", optional = true }
+iced_profiling = { version = "0.1.0", path = "profiling", optional = true }
thiserror = "1.0"
[dependencies.image_rs]