summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml45
1 files changed, 29 insertions, 16 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 60c60fbb..cffa5409 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "iced"
-version = "0.3.0"
+version = "0.4.2"
authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
edition = "2021"
description = "A cross-platform GUI library inspired by Elm"
@@ -14,24 +14,20 @@ resolver = "2"
[features]
default = ["wgpu"]
-# Enables the `iced_wgpu` renderer
-wgpu = ["iced_wgpu"]
# Enables the `Image` widget
image = ["iced_wgpu/image", "image_rs"]
# Enables the `Svg` widget
svg = ["iced_wgpu/svg"]
# Enables the `Canvas` widget
-canvas = ["iced_wgpu/canvas"]
+canvas = ["iced_graphics/canvas"]
# Enables the `QRCode` widget
-qr_code = ["iced_wgpu/qr_code"]
+qr_code = ["iced_graphics/qr_code"]
+# Enables the `iced_wgpu` renderer
+wgpu = ["iced_wgpu"]
# Enables using system fonts
default_system_font = ["iced_wgpu/default_system_font"]
# Enables the `iced_glow` renderer. Overrides `iced_wgpu`
glow = ["iced_glow", "iced_glutin"]
-# Enables the `Canvas` widget for `iced_glow`
-glow_canvas = ["iced_glow/canvas"]
-# Enables the `QRCode` widget for `iced_glow`
-glow_qr_code = ["iced_glow/qr_code"]
# Enables using system fonts for `iced_glow`
glow_default_system_font = ["iced_glow/default_system_font"]
# Enables a debug view in native platforms (press F12)
@@ -44,6 +40,8 @@ async-std = ["iced_futures/async-std"]
smol = ["iced_futures/smol"]
# Enables advanced color conversion via `palette`
palette = ["iced_core/palette"]
+# Enables querying system information
+system = ["iced_winit/system"]
[badges]
maintenance = { status = "actively-developed" }
@@ -60,6 +58,7 @@ members = [
"style",
"wgpu",
"winit",
+ "examples/arc",
"examples/bezier_tool",
"examples/clock",
"examples/color_palette",
@@ -79,10 +78,12 @@ members = [
"examples/progress_bar",
"examples/qr_code",
"examples/scrollable",
+ "examples/sierpinski_triangle",
"examples/solar_system",
"examples/stopwatch",
"examples/styling",
"examples/svg",
+ "examples/system_information",
"examples/todos",
"examples/tooltip",
"examples/tour",
@@ -91,11 +92,13 @@ members = [
]
[dependencies]
-iced_core = { version = "0.4", path = "core" }
-iced_futures = { version = "0.3", path = "futures" }
-iced_winit = { version = "0.3", path = "winit" }
-iced_glutin = { version = "0.2", path = "glutin", optional = true }
-iced_glow = { version = "0.2", path = "glow", optional = true }
+iced_core = { version = "0.5", path = "core" }
+iced_futures = { version = "0.4", path = "futures" }
+iced_native = { version = "0.5", path = "native" }
+iced_graphics = { version = "0.3", path = "graphics" }
+iced_winit = { version = "0.4", path = "winit" }
+iced_glutin = { version = "0.3", path = "glutin", optional = true }
+iced_glow = { version = "0.3", path = "glow", optional = true }
thiserror = "1.0"
[dependencies.image_rs]
@@ -104,11 +107,21 @@ package = "image"
optional = true
[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
-iced_wgpu = { version = "0.4", path = "wgpu", optional = true }
+iced_wgpu = { version = "0.5", path = "wgpu", optional = true }
[target.'cfg(target_arch = "wasm32")'.dependencies]
-iced_wgpu = { version = "0.4", path = "wgpu", features = ["webgl"], optional = true }
+iced_wgpu = { version = "0.5", path = "wgpu", features = ["webgl"], optional = true }
[package.metadata.docs.rs]
rustdoc-args = ["--cfg", "docsrs"]
features = ["image", "svg", "canvas", "qr_code"]
+
+[profile.release-opt]
+inherits = "release"
+codegen-units = 1
+debug = false
+lto = true
+incremental = false
+opt-level = 3
+overflow-checks = false
+strip = "debuginfo"