summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 11 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0975aeeb..08d51a0e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "iced"
-version = "0.1.0-alpha"
+version = "0.1.0-alpha.1"
authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
edition = "2018"
description = "A cross-platform GUI library inspired by Elm"
@@ -21,3 +21,13 @@ members = [
"web",
"examples/tour",
]
+
+[features]
+vulkan = ["iced_wgpu/vulkan"]
+
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
+iced_winit = { version = "0.1.0-alpha", path = "winit" }
+iced_wgpu = { version = "0.1.0-alpha", path = "wgpu" }
+
+[target.'cfg(target_arch = "wasm32")'.dependencies]
+iced_web = { version = "0.1.0-alpha", path = "web" }