summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Cargo.toml29
1 files changed, 13 insertions, 16 deletions
diff --git a/Cargo.toml b/Cargo.toml
index aeb8382e..28a97af9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -23,11 +23,24 @@ maintenance = { status = "actively-developed" }
[workspace]
members = [
"core",
+ "futures",
"native",
"style",
"web",
"wgpu",
"winit",
+ "examples/bezier_tool",
+ "examples/counter",
+ "examples/custom_widget",
+ "examples/events",
+ "examples/geometry",
+ "examples/pokedex",
+ "examples/progress_bar",
+ "examples/stopwatch",
+ "examples/styling",
+ "examples/svg",
+ "examples/todos",
+ "examples/tour",
]
[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
@@ -36,19 +49,3 @@ iced_wgpu = { version = "0.1.0", path = "wgpu" }
[target.'cfg(target_arch = "wasm32")'.dependencies]
iced_web = { version = "0.1.0", path = "web" }
-
-[dev-dependencies]
-iced_native = { version = "0.1", path = "./native" }
-iced_wgpu = { version = "0.1", path = "./wgpu" }
-env_logger = "0.7"
-serde = { version = "1.0", features = ["derive"] }
-serde_json = "1.0"
-directories = "2.0"
-futures = "0.3"
-async-std = { version = "1.3", features = ["unstable"] }
-surf = "1.0"
-rand = "0.7"
-lyon = "0.15"
-
-[target.'cfg(target_arch = "wasm32")'.dev-dependencies]
-wasm-bindgen = "0.2.51"