summaryrefslogtreecommitdiffstats
path: root/winit/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Richard <30560559+derezzedex@users.noreply.github.com>2024-09-13 19:15:15 -0300
committerLibravatar GitHub <noreply@github.com>2024-09-13 22:15:15 +0000
commitd46f6f92ce1f5f2776ab48f74dbd4439b1f17e9f (patch)
treed252d5393e9f2ede6b84f0978b14b9a5d4dfb3f3 /winit/Cargo.toml
parentf3b51e40f006bc7c6ee2d3560820c922081aa8b0 (diff)
downloadiced-d46f6f92ce1f5f2776ab48f74dbd4439b1f17e9f.tar.gz
iced-d46f6f92ce1f5f2776ab48f74dbd4439b1f17e9f.tar.bz2
iced-d46f6f92ce1f5f2776ab48f74dbd4439b1f17e9f.zip
Fix `wasm32` deployments not displaying anything (#2574)
* reuse `canvas` element generated by dummy window * fix formatting * set `control_flow` to `Poll` in `resumed` this is mostly a fix for Chrome * Avoid blowing up memory when booting up on Wasm --------- Co-authored-by: Héctor Ramón Jiménez <hector@hecrj.dev>
Diffstat (limited to 'winit/Cargo.toml')
-rw-r--r--winit/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/winit/Cargo.toml b/winit/Cargo.toml
index f5a47952..bd6feb00 100644
--- a/winit/Cargo.toml
+++ b/winit/Cargo.toml
@@ -44,5 +44,5 @@ winapi.workspace = true
[target.'cfg(target_arch = "wasm32")'.dependencies]
web-sys.workspace = true
-web-sys.features = ["Document", "Window"]
+web-sys.features = ["Document", "Window", "HtmlCanvasElement"]
wasm-bindgen-futures.workspace = true