summaryrefslogtreecommitdiffstats
path: root/winit/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2022-04-30 13:37:57 +0200
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2022-04-30 13:37:57 +0200
commit93bfe2c75ec97ef78f993926c703f040dde4a5f3 (patch)
tree80582ee46dfd06cf5f69d92e3b6d66c0c766c28e /winit/Cargo.toml
parent5eefa5d4ead9ebfac7dab1db9aebf9797d2dad38 (diff)
downloadiced-93bfe2c75ec97ef78f993926c703f040dde4a5f3.tar.gz
iced-93bfe2c75ec97ef78f993926c703f040dde4a5f3.tar.bz2
iced-93bfe2c75ec97ef78f993926c703f040dde4a5f3.zip
Expose `system` module through feature flag
Diffstat (limited to 'winit/Cargo.toml')
-rw-r--r--winit/Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/winit/Cargo.toml b/winit/Cargo.toml
index f5478e73..7758899c 100644
--- a/winit/Cargo.toml
+++ b/winit/Cargo.toml
@@ -12,12 +12,12 @@ categories = ["gui"]
[features]
debug = ["iced_native/debug"]
+system = ["sysinfo"]
[dependencies]
window_clipboard = "0.2"
log = "0.4"
thiserror = "1.0"
-sysinfo = "0.23"
[dependencies.winit]
version = "0.26"
@@ -42,3 +42,7 @@ version = "0.3.6"
[target.'cfg(target_arch = "wasm32")'.dependencies.web-sys]
version = "0.3"
features = ["Document", "Window"]
+
+[dependencies.sysinfo]
+version = "0.23"
+optional = true