summaryrefslogtreecommitdiffstats
path: root/winit/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón <hector0193@gmail.com>2022-05-11 18:08:36 +0200
committerLibravatar GitHub <noreply@github.com>2022-05-11 18:08:36 +0200
commit2e7757a42819fba3757c5b88e77e184b09649910 (patch)
tree80b0a55ff3834647a6527d8856632e79d8352789 /winit/Cargo.toml
parentd4ed8afa1ed15486144dc7afee52c09e044a92e0 (diff)
parentb440df9afbb2b63717e84d209a0995ada0e72e6d (diff)
downloadiced-2e7757a42819fba3757c5b88e77e184b09649910.tar.gz
iced-2e7757a42819fba3757c5b88e77e184b09649910.tar.bz2
iced-2e7757a42819fba3757c5b88e77e184b09649910.zip
Merge pull request #1314 from derezzedex/dev/system-information
feat: fetch system information
Diffstat (limited to 'winit/Cargo.toml')
-rw-r--r--winit/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/winit/Cargo.toml b/winit/Cargo.toml
index 2beebdfb..3b9ae859 100644
--- a/winit/Cargo.toml
+++ b/winit/Cargo.toml
@@ -12,6 +12,7 @@ categories = ["gui"]
[features]
debug = ["iced_native/debug"]
+system = ["sysinfo"]
[dependencies]
window_clipboard = "0.2"
@@ -41,3 +42,7 @@ version = "0.3.6"
[target.'cfg(target_arch = "wasm32")'.dependencies.web-sys]
version = "0.3"
features = ["Document", "Window"]
+
+[dependencies.sysinfo]
+version = "0.23"
+optional = true