summaryrefslogtreecommitdiffstats
path: root/winit/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón <hector0193@gmail.com>2023-01-09 19:10:45 +0100
committerLibravatar GitHub <noreply@github.com>2023-01-09 19:10:45 +0100
commit07d755c6a270bd46fe9752ed57b3ceaddda1f081 (patch)
treecbd8f75d8cd6beeb3c04cbedc0127f2e17b70f56 /winit/Cargo.toml
parentba20ac8e49aedfa9d822d71784587d0635cec4f8 (diff)
parent2e5dc1f37a32e1f3aaa6db2aa9cf9c95e83bff42 (diff)
downloadiced-07d755c6a270bd46fe9752ed57b3ceaddda1f081.tar.gz
iced-07d755c6a270bd46fe9752ed57b3ceaddda1f081.tar.bz2
iced-07d755c6a270bd46fe9752ed57b3ceaddda1f081.zip
Merge pull request #1565 from bungoboingo/feat/tracing
[Feature] Profiling
Diffstat (limited to 'winit/Cargo.toml')
-rw-r--r--winit/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/winit/Cargo.toml b/winit/Cargo.toml
index ebbadb12..94aaa2ca 100644
--- a/winit/Cargo.toml
+++ b/winit/Cargo.toml
@@ -11,6 +11,8 @@ keywords = ["gui", "ui", "graphics", "interface", "widgets"]
categories = ["gui"]
[features]
+trace = ["tracing", "tracing-core", "tracing-subscriber"]
+chrome-trace = ["trace", "tracing-chrome"]
debug = ["iced_native/debug"]
system = ["sysinfo"]
application = []
@@ -37,6 +39,24 @@ path = "../graphics"
version = "0.5"
path = "../futures"
+[dependencies.tracing]
+version = "0.1.37"
+optional = true
+features = ["std"]
+
+[dependencies.tracing-core]
+version = "0.1.30"
+optional = true
+
+[dependencies.tracing-subscriber]
+version = "0.3.16"
+optional = true
+features = ["registry"]
+
+[dependencies.tracing-chrome]
+version = "0.7.0"
+optional = true
+
[target.'cfg(target_os = "windows")'.dependencies.winapi]
version = "0.3.6"