summaryrefslogtreecommitdiffstats
path: root/widget/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2024-07-18 14:34:00 +0200
committerLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2024-07-18 14:34:00 +0200
commit47b7a36f36b99e346909390621b04f6691ff46d4 (patch)
treeab3d5c7ca7c81eb14fd5e2b0332e63fe68a6a7f8 /widget/Cargo.toml
parentaa62fa2ce992949d20ddbe8683ed2be0d922a568 (diff)
downloadiced-47b7a36f36b99e346909390621b04f6691ff46d4.tar.gz
iced-47b7a36f36b99e346909390621b04f6691ff46d4.tar.bz2
iced-47b7a36f36b99e346909390621b04f6691ff46d4.zip
Create `markdown` widget helpers in `iced_widget`
Diffstat (limited to 'widget/Cargo.toml')
-rw-r--r--widget/Cargo.toml10
1 files changed, 9 insertions, 1 deletions
diff --git a/widget/Cargo.toml b/widget/Cargo.toml
index 498a768b..2f483b79 100644
--- a/widget/Cargo.toml
+++ b/widget/Cargo.toml
@@ -22,8 +22,10 @@ lazy = ["ouroboros"]
image = ["iced_renderer/image"]
svg = ["iced_renderer/svg"]
canvas = ["iced_renderer/geometry"]
-qr_code = ["canvas", "qrcode"]
+qr_code = ["canvas", "dep:qrcode"]
wgpu = ["iced_renderer/wgpu"]
+markdown = ["dep:pulldown-cmark"]
+highlighter = ["dep:iced_highlighter"]
advanced = []
[dependencies]
@@ -41,3 +43,9 @@ ouroboros.optional = true
qrcode.workspace = true
qrcode.optional = true
+
+pulldown-cmark.workspace = true
+pulldown-cmark.optional = true
+
+iced_highlighter.workspace = true
+iced_highlighter.optional = true