summaryrefslogtreecommitdiffstats
path: root/wgpu/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-01-20 11:19:42 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-01-20 11:19:42 +0100
commitbc611cf51cd35bb3a4b91500c8a13202db58ac38 (patch)
tree38d04730584ca63fac40e8902eaf03b01bc077fe /wgpu/Cargo.toml
parent91d9d65a03ce9b211e4043726e7424949d314325 (diff)
downloadiced-bc611cf51cd35bb3a4b91500c8a13202db58ac38.tar.gz
iced-bc611cf51cd35bb3a4b91500c8a13202db58ac38.tar.bz2
iced-bc611cf51cd35bb3a4b91500c8a13202db58ac38.zip
Make `image` support optional in `iced_wgpu`
This reduces binary size when image rendering is not necessary a considerable amount.
Diffstat (limited to 'wgpu/Cargo.toml')
-rw-r--r--wgpu/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/wgpu/Cargo.toml b/wgpu/Cargo.toml
index 19d41bba..60b98b40 100644
--- a/wgpu/Cargo.toml
+++ b/wgpu/Cargo.toml
@@ -17,8 +17,8 @@ wgpu = "0.4"
glyph_brush = "0.6"
wgpu_glyph = { version = "0.7", git = "https://github.com/hecrj/wgpu_glyph", branch = "fix/font-load-panic" }
raw-window-handle = "0.3"
-image = "0.22"
glam = "0.8"
font-kit = "0.4"
log = "0.4"
resvg = { version = "0.8", features = ["raqote-backend"], optional = true }
+image = { version = "0.22", optional = true }