summaryrefslogtreecommitdiffstats
path: root/wgpu/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-09-04 03:28:45 +0200
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-09-04 03:28:45 +0200
commitbb49a22996f39e32c3ced0c2d80c2137aed7a0ea (patch)
tree80559ea7e79458b20acb390b08b9dcf555dba4d4 /wgpu/Cargo.toml
parent2c51e3478bfb1c53ea7e63b1f1dc74ec46faa748 (diff)
downloadiced-bb49a22996f39e32c3ced0c2d80c2137aed7a0ea.tar.gz
iced-bb49a22996f39e32c3ced0c2d80c2137aed7a0ea.tar.bz2
iced-bb49a22996f39e32c3ced0c2d80c2137aed7a0ea.zip
Enable WebGPU backend in `wgpu` by default instead of WebGL
Instead, we expose a new `webgl` feature.
Diffstat (limited to 'wgpu/Cargo.toml')
-rw-r--r--wgpu/Cargo.toml4
1 files changed, 1 insertions, 3 deletions
diff --git a/wgpu/Cargo.toml b/wgpu/Cargo.toml
index b0f70220..49c62673 100644
--- a/wgpu/Cargo.toml
+++ b/wgpu/Cargo.toml
@@ -12,6 +12,7 @@ geometry = ["iced_graphics/geometry", "lyon"]
image = ["iced_graphics/image"]
svg = ["resvg"]
web-colors = ["iced_graphics/web-colors"]
+webgl = ["wgpu/webgl"]
[dependencies]
wgpu = "0.17"
@@ -24,9 +25,6 @@ once_cell = "1.0"
rustc-hash = "1.1"
log = "0.4"
-[target.'cfg(target_arch = "wasm32")'.dependencies]
-wgpu = { version = "0.17", features = ["webgl"] }
-
[dependencies.twox-hash]
version = "1.6"
default-features = false