summaryrefslogtreecommitdiffstats
path: root/wgpu/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-02-11 23:14:25 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2020-02-11 23:14:25 +0100
commit8daf798e5760a0d35d5491027d51a5dd96898b0d (patch)
treee8c6f71e2ac412112e6f32bdb6f816dbabb8b407 /wgpu/Cargo.toml
parent3a00f3398cf2b04fc08454b15f5b7dbc4272f259 (diff)
downloadiced-8daf798e5760a0d35d5491027d51a5dd96898b0d.tar.gz
iced-8daf798e5760a0d35d5491027d51a5dd96898b0d.tar.bz2
iced-8daf798e5760a0d35d5491027d51a5dd96898b0d.zip
Add `canvas` feature to `iced_wgpu`
And prepare `canvas` module
Diffstat (limited to 'wgpu/Cargo.toml')
-rw-r--r--wgpu/Cargo.toml16
1 files changed, 14 insertions, 2 deletions
diff --git a/wgpu/Cargo.toml b/wgpu/Cargo.toml
index 60b98b40..887c2d21 100644
--- a/wgpu/Cargo.toml
+++ b/wgpu/Cargo.toml
@@ -9,6 +9,7 @@ repository = "https://github.com/hecrj/iced"
[features]
svg = ["resvg"]
+canvas = ["lyon"]
[dependencies]
iced_native = { version = "0.1.0", path = "../native" }
@@ -20,5 +21,16 @@ raw-window-handle = "0.3"
glam = "0.8"
font-kit = "0.4"
log = "0.4"
-resvg = { version = "0.8", features = ["raqote-backend"], optional = true }
-image = { version = "0.22", optional = true }
+
+[dependencies.image]
+version = "0.22"
+optional = true
+
+[dependencies.resvg]
+version = "0.8"
+features = ["raqote-backend"]
+optional = true
+
+[dependencies.lyon]
+version = "0.15"
+optional = true