summaryrefslogtreecommitdiffstats
path: root/wgpu/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2019-12-15 06:45:20 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2019-12-15 06:45:20 +0100
commit232d4873ba0fb9b87d08c8d70b117e81aa7489b5 (patch)
treebfaac8e4887bbb0ea4ffa6a687151e13f4ae093e /wgpu/Cargo.toml
parentaa298499768bb50129cc3bd0dca6f3f858e5802e (diff)
downloadiced-232d4873ba0fb9b87d08c8d70b117e81aa7489b5.tar.gz
iced-232d4873ba0fb9b87d08c8d70b117e81aa7489b5.tar.bz2
iced-232d4873ba0fb9b87d08c8d70b117e81aa7489b5.zip
Put `svg` rendering behind a feature gate
This reduces binary size when SVG supoprt is not needed.
Diffstat (limited to 'wgpu/Cargo.toml')
-rw-r--r--wgpu/Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/wgpu/Cargo.toml b/wgpu/Cargo.toml
index e8e9c877..bb241914 100644
--- a/wgpu/Cargo.toml
+++ b/wgpu/Cargo.toml
@@ -7,6 +7,9 @@ description = "A wgpu renderer for Iced"
license = "MIT AND OFL-1.1"
repository = "https://github.com/hecrj/iced"
+[features]
+svg = ["resvg"]
+
[dependencies]
iced_native = { version = "0.1.0", path = "../native" }
wgpu = "0.4"
@@ -17,4 +20,4 @@ image = "0.22"
glam = "0.8"
font-kit = "0.4"
log = "0.4"
-resvg = { version = "0.8", features = ["raqote-backend"] }
+resvg = { version = "0.8", features = ["raqote-backend"], optional = true }