summaryrefslogtreecommitdiffstats
path: root/wgpu/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-03-05 06:40:20 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-03-05 06:40:20 +0100
commit06bbcc310e6e759a0839df6ca391ea5e0f0ee609 (patch)
tree782023181c77ce9ba2b836b0e82a671341b82213 /wgpu/Cargo.toml
parent1c36446115dcb46c373fbc62b9e4f1941bd5a383 (diff)
downloadiced-06bbcc310e6e759a0839df6ca391ea5e0f0ee609.tar.gz
iced-06bbcc310e6e759a0839df6ca391ea5e0f0ee609.tar.bz2
iced-06bbcc310e6e759a0839df6ca391ea5e0f0ee609.zip
Move `webgl` feature selection for `wgpu` into `iced_wgpu`
Diffstat (limited to 'wgpu/Cargo.toml')
-rw-r--r--wgpu/Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/wgpu/Cargo.toml b/wgpu/Cargo.toml
index 50a81a91..5601c0de 100644
--- a/wgpu/Cargo.toml
+++ b/wgpu/Cargo.toml
@@ -23,7 +23,6 @@ dds = ["iced_graphics/dds"]
farbfeld = ["iced_graphics/farbfeld"]
geometry = ["iced_graphics/geometry", "lyon"]
spirv = ["wgpu/spirv"]
-webgl = ["wgpu/webgl"]
[dependencies]
wgpu = "0.14"
@@ -36,6 +35,9 @@ once_cell = "1.0"
rustc-hash = "1.1"
ouroboros = "0.15"
+[target.'cfg(target_arch = "wasm32")'.dependencies]
+wgpu = { version = "0.14", features = ["webgl"] }
+
[dependencies.twox-hash]
version = "1.6"
default-features = false