summaryrefslogtreecommitdiffstats
path: root/wgpu/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-02-04 12:42:02 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-02-24 13:31:19 +0100
commitda4182099db703d59006ca72de4cb4d54c9d7855 (patch)
treeb9963333dea5d5db5ff78082e6b6a4edb27eaab0 /wgpu/Cargo.toml
parent17470bf7d36ee164311020b9d8c79662ac49c166 (diff)
downloadiced-da4182099db703d59006ca72de4cb4d54c9d7855.tar.gz
iced-da4182099db703d59006ca72de4cb4d54c9d7855.tar.bz2
iced-da4182099db703d59006ca72de4cb4d54c9d7855.zip
Disable `std` feature for `twox-hash` to fix Wasm build
Diffstat (limited to '')
-rw-r--r--wgpu/Cargo.toml9
1 files changed, 8 insertions, 1 deletions
diff --git a/wgpu/Cargo.toml b/wgpu/Cargo.toml
index 1ab3d93f..0d9fb75b 100644
--- a/wgpu/Cargo.toml
+++ b/wgpu/Cargo.toml
@@ -35,9 +35,16 @@ futures = "0.3"
bitflags = "1.2"
once_cell = "1.0"
rustc-hash = "1.1"
-twox-hash = "1.6"
ouroboros = "0.15"
+[dependencies.twox-hash]
+version = "1.6"
+default-features = false
+
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies.twox-hash]
+version = "1.6.1"
+features = ["std"]
+
[dependencies.bytemuck]
version = "1.9"
features = ["derive"]