summaryrefslogtreecommitdiffstats
path: root/web/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón <hector0193@gmail.com>2019-09-24 15:39:33 +0200
committerLibravatar GitHub <noreply@github.com>2019-09-24 15:39:33 +0200
commit68c4752e998dca1d618380ce4e7d8ac52b710056 (patch)
tree35e386030b072c189509bb2ed3adeaec5b0fd4d1 /web/Cargo.toml
parentbb5cac49d028eb53c259ae58e3a007ebfb736fd4 (diff)
parent05c7c39ecb8910c75b82dc4052a7720fb2d42b4a (diff)
downloadiced-68c4752e998dca1d618380ce4e7d8ac52b710056.tar.gz
iced-68c4752e998dca1d618380ce4e7d8ac52b710056.tar.bz2
iced-68c4752e998dca1d618380ce4e7d8ac52b710056.zip
Merge pull request #17 from hecrj/web
Basic web support (core, native, and web crates)
Diffstat (limited to 'web/Cargo.toml')
-rw-r--r--web/Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/web/Cargo.toml b/web/Cargo.toml
new file mode 100644
index 00000000..d5a987b0
--- /dev/null
+++ b/web/Cargo.toml
@@ -0,0 +1,33 @@
+[package]
+name = "iced_web"
+version = "0.1.0-alpha"
+authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
+edition = "2018"
+description = "A web backend for Iced"
+license = "MIT"
+repository = "https://github.com/hecrj/iced"
+documentation = "https://docs.rs/iced_web"
+readme = "README.md"
+keywords = ["gui", "ui", "web", "interface", "widgets"]
+categories = ["web-programming"]
+
+[badges]
+maintenance = { status = "actively-developed" }
+
+[dependencies]
+iced_core = { version = "0.1.0-alpha", path = "../core" }
+dodrio = "0.1.0"
+futures-preview = "=0.3.0-alpha.18"
+wasm-bindgen = "0.2.50"
+
+[dependencies.web-sys]
+version = "0.3.27"
+features = [
+ "console",
+ "Document",
+ "HtmlElement",
+ "HtmlInputElement",
+ "Event",
+ "EventTarget",
+ "InputEvent",
+]