summaryrefslogtreecommitdiffstats
path: root/web/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Liam Murphy <liampm32@gmail.com>2021-03-21 14:36:06 +1100
committerLibravatar Liam Murphy <liampm32@gmail.com>2021-03-21 14:36:06 +1100
commit1d85b6e887761ae885bec3f0b5405bf902ef8b64 (patch)
tree5a1595e91a8f7f9c3fff91b0a1d5528249abef04 /web/Cargo.toml
parent0333a8daff6db989adc6035a4c09df171a86f6fe (diff)
downloadiced-1d85b6e887761ae885bec3f0b5405bf902ef8b64.tar.gz
iced-1d85b6e887761ae885bec3f0b5405bf902ef8b64.tar.bz2
iced-1d85b6e887761ae885bec3f0b5405bf902ef8b64.zip
feat(web): Support in-memory image data
I had to create two methods which basically do the same thing, `from_memory` and `from_slice`, but `from_memory` takes ownership of the bytes to be compatible with `iced_native`. Also, `Data` is incompatible, because if I stored the bytes in `Data` and created a new object URL every render, it would have caused a memory leak because bumpalo doesn't call destructors and there'd be no way to call URL.revokeObjectUrl on it. It's also more efficient this way.
Diffstat (limited to 'web/Cargo.toml')
-rw-r--r--web/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/web/Cargo.toml b/web/Cargo.toml
index e063a021..b3f9ec31 100644
--- a/web/Cargo.toml
+++ b/web/Cargo.toml
@@ -20,6 +20,7 @@ wasm-bindgen = "0.2"
wasm-bindgen-futures = "0.4"
url = "2.0"
num-traits = "0.2"
+js-sys = "0.3"
[dependencies.iced_core]
version = "0.3"
@@ -44,4 +45,5 @@ features = [
"EventTarget",
"InputEvent",
"KeyboardEvent",
+ "Url",
]