summaryrefslogtreecommitdiffstats
path: root/web/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Liam Murphy <liampm32@gmail.com>2021-04-10 17:18:04 +1000
committerLibravatar Liam Murphy <liampm32@gmail.com>2021-04-10 17:18:04 +1000
commit11f29bca86e299ed3e2c0d3db0d8058efe4be7ef (patch)
tree960b17ec45e5e33a3a8492e7cdcefeca8acaf75d /web/Cargo.toml
parent99c56b9bff891d55794dccc20f460192ff06f0b8 (diff)
downloadiced-11f29bca86e299ed3e2c0d3db0d8058efe4be7ef.tar.gz
iced-11f29bca86e299ed3e2c0d3db0d8058efe4be7ef.tar.bz2
iced-11f29bca86e299ed3e2c0d3db0d8058efe4be7ef.zip
Use data urls instead of blob URLs
I didn't do this originally because I was half doing it in the first place to mess with Blob URLs, and it feels kinda wrong to be encoding it as base64 when that option is available. But not having memory leaks is more important.
Diffstat (limited to 'web/Cargo.toml')
-rw-r--r--web/Cargo.toml4
1 files changed, 1 insertions, 3 deletions
diff --git a/web/Cargo.toml b/web/Cargo.toml
index d6bc34da..f8630780 100644
--- a/web/Cargo.toml
+++ b/web/Cargo.toml
@@ -20,7 +20,7 @@ wasm-bindgen = "0.2"
wasm-bindgen-futures = "0.4"
url = "2.0"
num-traits = "0.2"
-js-sys = "0.3"
+base64 = "0.13"
[dependencies.iced_core]
version = "0.3"
@@ -45,6 +45,4 @@ features = [
"EventTarget",
"InputEvent",
"KeyboardEvent",
- "Url",
- "Blob",
]