summaryrefslogtreecommitdiffstats
path: root/tiny_skia/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar dtzxporter <dtzxporter@users.noreply.github.com>2023-09-12 18:15:00 -0400
committerLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2023-11-11 03:40:22 +0100
commit98e088e731e6fbd5b5035033ae61bda823ced988 (patch)
tree4e12f49f37ad6d5c6dffd06bc7fabc05930db3e1 /tiny_skia/Cargo.toml
parent751ea77c29f6eb3d00f45f0a04c833a1d03a425c (diff)
downloadiced-98e088e731e6fbd5b5035033ae61bda823ced988.tar.gz
iced-98e088e731e6fbd5b5035033ae61bda823ced988.tar.bz2
iced-98e088e731e6fbd5b5035033ae61bda823ced988.zip
Migrate twox-hash -> xxhash_rust. Switch to Xxh3 for better performance.
xxhash-rust is more maintained, built against `::core`, so no workaround for wasm is necessary. Switch to Xxh3 for better performance, which shows when loading/hashing image buffers.
Diffstat (limited to 'tiny_skia/Cargo.toml')
-rw-r--r--tiny_skia/Cargo.toml6
1 files changed, 1 insertions, 5 deletions
diff --git a/tiny_skia/Cargo.toml b/tiny_skia/Cargo.toml
index 15a6928a..df4c6143 100644
--- a/tiny_skia/Cargo.toml
+++ b/tiny_skia/Cargo.toml
@@ -26,11 +26,7 @@ raw-window-handle.workspace = true
rustc-hash.workspace = true
softbuffer.workspace = true
tiny-skia.workspace = true
-twox-hash.workspace = true
+xxhash-rust.workspace = true
resvg.workspace = true
resvg.optional = true
-
-[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
-twox-hash.workspace = true
-twox-hash.features = ["std"]