summaryrefslogtreecommitdiffstats
path: root/tiny_skia/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-04-05 19:30:07 +0200
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-04-05 19:30:07 +0200
commit940a47eafd098dce3567a95c38dc8697b0fc7115 (patch)
treea0bc0627efa629e98f63ccd66ef9b6964b458006 /tiny_skia/Cargo.toml
parent92d61e5c592818745abbab245a82cb14b262ae67 (diff)
downloadiced-940a47eafd098dce3567a95c38dc8697b0fc7115.tar.gz
iced-940a47eafd098dce3567a95c38dc8697b0fc7115.tar.bz2
iced-940a47eafd098dce3567a95c38dc8697b0fc7115.zip
Revert "Use `softbuffer` fork with owned pixel buffer"
This reverts commit 92d61e5c592818745abbab245a82cb14b262ae67. The owned pixel buffer zeroes the data in some platforms. `softbuffer` will need some first-class support for damage regions.
Diffstat (limited to 'tiny_skia/Cargo.toml')
-rw-r--r--tiny_skia/Cargo.toml5
1 files changed, 1 insertions, 4 deletions
diff --git a/tiny_skia/Cargo.toml b/tiny_skia/Cargo.toml
index db590fc2..349f6903 100644
--- a/tiny_skia/Cargo.toml
+++ b/tiny_skia/Cargo.toml
@@ -10,6 +10,7 @@ geometry = ["iced_graphics/geometry"]
[dependencies]
raw-window-handle = "0.5"
+softbuffer = "0.2"
tiny-skia = "0.8"
bytemuck = "1"
rustc-hash = "1.1"
@@ -21,10 +22,6 @@ version = "0.7"
path = "../graphics"
features = ["tiny-skia"]
-[dependencies.softbuffer]
-git = "https://github.com/rust-windowing/softbuffer"
-rev = "872c66a4c05fd7cb6cb133154f75fdce45a175a6"
-
[dependencies.cosmic-text]
features = ["std", "swash"]
git = "https://github.com/pop-os/cosmic-text"