summaryrefslogtreecommitdiffstats
path: root/tiny_skia/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-04-05 19:23:48 +0200
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-04-05 19:23:48 +0200
commit92d61e5c592818745abbab245a82cb14b262ae67 (patch)
treed4194046ad862fd4fa2703186a70c275defb5c50 /tiny_skia/Cargo.toml
parente134a82f4ca67346fc9095a0d488122737cfb0d8 (diff)
downloadiced-92d61e5c592818745abbab245a82cb14b262ae67.tar.gz
iced-92d61e5c592818745abbab245a82cb14b262ae67.tar.bz2
iced-92d61e5c592818745abbab245a82cb14b262ae67.zip
Use `softbuffer` fork with owned pixel buffer
Diffstat (limited to 'tiny_skia/Cargo.toml')
-rw-r--r--tiny_skia/Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/tiny_skia/Cargo.toml b/tiny_skia/Cargo.toml
index 349f6903..db590fc2 100644
--- a/tiny_skia/Cargo.toml
+++ b/tiny_skia/Cargo.toml
@@ -10,7 +10,6 @@ geometry = ["iced_graphics/geometry"]
[dependencies]
raw-window-handle = "0.5"
-softbuffer = "0.2"
tiny-skia = "0.8"
bytemuck = "1"
rustc-hash = "1.1"
@@ -22,6 +21,10 @@ version = "0.7"
path = "../graphics"
features = ["tiny-skia"]
+[dependencies.softbuffer]
+git = "https://github.com/rust-windowing/softbuffer"
+rev = "872c66a4c05fd7cb6cb133154f75fdce45a175a6"
+
[dependencies.cosmic-text]
features = ["std", "swash"]
git = "https://github.com/pop-os/cosmic-text"