summaryrefslogtreecommitdiffstats
path: root/tiny_skia/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-02-26 23:40:17 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-02-26 23:40:17 +0100
commit64fb722dfe8769d4a92edb0133f1863383ecfd86 (patch)
tree1cc23b5a3d1ce49b4838ce50d906ef32524165e3 /tiny_skia/Cargo.toml
parent744f3028f484c44899fed56d9190387569828a95 (diff)
downloadiced-64fb722dfe8769d4a92edb0133f1863383ecfd86.tar.gz
iced-64fb722dfe8769d4a92edb0133f1863383ecfd86.tar.bz2
iced-64fb722dfe8769d4a92edb0133f1863383ecfd86.zip
Draft text support in `iced_tiny_skia`
Diffstat (limited to 'tiny_skia/Cargo.toml')
-rw-r--r--tiny_skia/Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/tiny_skia/Cargo.toml b/tiny_skia/Cargo.toml
index 70b1f5e7..55f7f5b7 100644
--- a/tiny_skia/Cargo.toml
+++ b/tiny_skia/Cargo.toml
@@ -12,6 +12,8 @@ raw-window-handle = "0.5"
softbuffer = "0.2"
tiny-skia = "0.8"
bytemuck = "1"
+rustc-hash = "1.1"
+ouroboros = "0.15"
[dependencies.iced_native]
version = "0.9"
@@ -20,3 +22,16 @@ path = "../native"
[dependencies.iced_graphics]
version = "0.7"
path = "../graphics"
+
+[dependencies.cosmic-text]
+features = ["std", "swash"]
+git = "https://github.com/hecrj/cosmic-text"
+rev = "dc83efbf00a2efb4118403538e8a47bfd69c3e5e"
+
+[dependencies.twox-hash]
+version = "1.6"
+default-features = false
+
+[target.'cfg(not(target_arch = "wasm32"))'.dependencies.twox-hash]
+version = "1.6.1"
+features = ["std"]