summaryrefslogtreecommitdiffstats
path: root/tiny_skia/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-04-08 05:58:27 +0200
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-04-08 05:58:27 +0200
commit16e6efe020e75d51958875fa198196534679af8d (patch)
treea8750a35f0131845b1f7dc87a356de56904f9998 /tiny_skia/Cargo.toml
parent3ee367355d4534d4eabcf2b135d64dc405984aa4 (diff)
downloadiced-16e6efe020e75d51958875fa198196534679af8d.tar.gz
iced-16e6efe020e75d51958875fa198196534679af8d.tar.bz2
iced-16e6efe020e75d51958875fa198196534679af8d.zip
Use `pixels` for presentation in `iced_tiny_skia` when possible
Diffstat (limited to 'tiny_skia/Cargo.toml')
-rw-r--r--tiny_skia/Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/tiny_skia/Cargo.toml b/tiny_skia/Cargo.toml
index 7a5f5b17..731e06de 100644
--- a/tiny_skia/Cargo.toml
+++ b/tiny_skia/Cargo.toml
@@ -4,6 +4,8 @@ version = "0.1.0"
edition = "2021"
[features]
+default = ["gpu"]
+gpu = ["pixels"]
image = ["iced_graphics/image"]
svg = ["resvg"]
geometry = ["iced_graphics/geometry"]
@@ -31,6 +33,10 @@ default-features = false
version = "1.6.1"
features = ["std"]
+[dependencies.pixels]
+version = "0.12"
+optional = true
+
[dependencies.resvg]
version = "0.29"
optional = true