summaryrefslogtreecommitdiffstats
path: root/style/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Ian Douglas Scott <idscott@system76.com>2022-10-28 14:43:18 -0700
committerLibravatar Ian Douglas Scott <idscott@system76.com>2022-10-28 15:58:21 -0700
commitbe9cd3a09f4fb027786c634158ddeaca75a169f0 (patch)
tree3685a32b728bf6cfe426f46c437574f62a3d53db /style/Cargo.toml
parent82217947aa80287282ed6deb02d238a31303e0d6 (diff)
downloadiced-be9cd3a09f4fb027786c634158ddeaca75a169f0.tar.gz
iced-be9cd3a09f4fb027786c634158ddeaca75a169f0.tar.bz2
iced-be9cd3a09f4fb027786c634158ddeaca75a169f0.zip
Use `once_cell` instead of `lazy_static`
This seems to be generally considered the preferred, idiomatic solution now. This is in the standard library behind a feature flag (apparently now called `std::sync::LazyLock`).
Diffstat (limited to 'style/Cargo.toml')
-rw-r--r--style/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/style/Cargo.toml b/style/Cargo.toml
index cf9d328b..4a482a4f 100644
--- a/style/Cargo.toml
+++ b/style/Cargo.toml
@@ -18,5 +18,5 @@ features = ["palette"]
[dependencies.palette]
version = "0.6"
-[dependencies.lazy_static]
-version = "1.4"
+[dependencies.once_cell]
+version = "1.15"