summaryrefslogtreecommitdiffstats
path: root/runtime/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-09-04 12:58:41 +0200
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-09-04 13:08:17 +0200
commitf468e25d0c67a01ee79d892f6e8ba9be019f06c7 (patch)
treec099dc3a7c4ef6faa5ce762832a286d0a55ec316 /runtime/Cargo.toml
parenta56b25b9096d47ada3c4349f5b91110dfaa92bf6 (diff)
downloadiced-f468e25d0c67a01ee79d892f6e8ba9be019f06c7.tar.gz
iced-f468e25d0c67a01ee79d892f6e8ba9be019f06c7.tar.bz2
iced-f468e25d0c67a01ee79d892f6e8ba9be019f06c7.zip
Use workspace dependencies and package inheritance
We are also taking this as a chance to synchronize the versions of all the crates! Because of this, we will skip the `0.11` version.
Diffstat (limited to 'runtime/Cargo.toml')
-rw-r--r--runtime/Cargo.toml28
1 files changed, 13 insertions, 15 deletions
diff --git a/runtime/Cargo.toml b/runtime/Cargo.toml
index 9fbe4be7..d19aedd3 100644
--- a/runtime/Cargo.toml
+++ b/runtime/Cargo.toml
@@ -1,23 +1,21 @@
[package]
name = "iced_runtime"
-version = "0.1.1"
-authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
-edition = "2021"
-description = "A renderer-agnostic runtime for Iced"
-license = "MIT"
-repository = "https://github.com/iced-rs/iced"
+description = "A renderer-agnostic runtime for iced"
+version.workspace = true
+edition.workspace = true
+authors.workspace = true
+license.workspace = true
+repository.workspace = true
+homepage.workspace = true
+categories.workspace = true
+keywords.workspace = true
[features]
debug = []
[dependencies]
-thiserror = "1"
+iced_core.workspace = true
+iced_futures.workspace = true
+iced_futures.features = ["thread-pool"]
-[dependencies.iced_core]
-version = "0.10"
-path = "../core"
-
-[dependencies.iced_futures]
-version = "0.7"
-path = "../futures"
-features = ["thread-pool"]
+thiserror.workspace = true