summaryrefslogtreecommitdiffstats
path: root/runtime/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Bingus <shankern@protonmail.com>2023-07-12 12:23:18 -0700
committerLibravatar Bingus <shankern@protonmail.com>2023-07-12 12:23:18 -0700
commit633f405f3f78bc7f82d2b2061491b0e011137451 (patch)
tree5ebfc1f45d216a5c14a90492563599e6969eab4d /runtime/Cargo.toml
parent41836dd80d0534608e7aedfbf2319c540a23de1a (diff)
parent21bd51426d900e271206f314e0c915dd41065521 (diff)
downloadiced-633f405f3f78bc7f82d2b2061491b0e011137451.tar.gz
iced-633f405f3f78bc7f82d2b2061491b0e011137451.tar.bz2
iced-633f405f3f78bc7f82d2b2061491b0e011137451.zip
Merge remote-tracking branch 'origin/master' into feat/multi-window-support
# Conflicts: # Cargo.toml # core/src/window/icon.rs # core/src/window/id.rs # core/src/window/position.rs # core/src/window/settings.rs # examples/integration/src/main.rs # examples/integration_opengl/src/main.rs # glutin/src/application.rs # native/src/subscription.rs # native/src/window.rs # runtime/src/window/action.rs # src/lib.rs # src/window.rs # winit/Cargo.toml # winit/src/application.rs # winit/src/icon.rs # winit/src/settings.rs # winit/src/window.rs
Diffstat (limited to 'runtime/Cargo.toml')
-rw-r--r--runtime/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/runtime/Cargo.toml b/runtime/Cargo.toml
new file mode 100644
index 00000000..a65f07f2
--- /dev/null
+++ b/runtime/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "iced_runtime"
+version = "0.1.0"
+authors = ["Héctor Ramón Jiménez <hector0193@gmail.com>"]
+edition = "2021"
+description = "A renderer-agnostic library for native GUIs"
+license = "MIT"
+repository = "https://github.com/iced-rs/iced"
+
+[features]
+debug = []
+
+[dependencies]
+thiserror = "1"
+
+[dependencies.iced_core]
+version = "0.9"
+path = "../core"
+
+[dependencies.iced_futures]
+version = "0.6"
+path = "../futures"
+features = ["thread-pool"]