summaryrefslogtreecommitdiffstats
path: root/renderer/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-02-25 15:38:25 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-02-25 15:38:25 +0100
commit8c373cd497e370d356b480380482779397bdb510 (patch)
treef640a1161e702cbb981d3b89f3e7a11ee390923c /renderer/Cargo.toml
parenta01bc865a0561ff1daf255c4746746acf67524f0 (diff)
downloadiced-8c373cd497e370d356b480380482779397bdb510.tar.gz
iced-8c373cd497e370d356b480380482779397bdb510.tar.bz2
iced-8c373cd497e370d356b480380482779397bdb510.zip
Scaffold `iced_tiny_skia` and connect it to `iced_renderer`
Diffstat (limited to 'renderer/Cargo.toml')
-rw-r--r--renderer/Cargo.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/renderer/Cargo.toml b/renderer/Cargo.toml
index 2a179f3a..5ba5d426 100644
--- a/renderer/Cargo.toml
+++ b/renderer/Cargo.toml
@@ -4,8 +4,8 @@ version = "0.1.0"
edition = "2021"
[features]
-image = ["iced_wgpu/image"]
-svg = ["iced_wgpu/svg"]
+image = ["iced_wgpu/image", "iced_tiny_skia/image"]
+svg = ["iced_wgpu/svg", "iced_tiny_skia/svg"]
tracing = ["iced_wgpu/tracing"]
[dependencies]
@@ -19,6 +19,10 @@ path = "../native"
version = "0.7"
path = "../graphics"
+[dependencies.iced_tiny_skia]
+version = "0.1"
+path = "../tiny_skia"
+
[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
iced_wgpu = { version = "0.9", path = "../wgpu" }