summaryrefslogtreecommitdiffstats
path: root/native/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2022-01-28 17:05:09 +0700
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2022-01-28 21:37:16 +0700
commit87b3e03d187237f665b376018ea5af0cc5f05814 (patch)
tree71509d53f85ed76b1ad2d187652d818230618767 /native/Cargo.toml
parent776724162aa4351310de9f88c7bb8d61b0abca04 (diff)
downloadiced-87b3e03d187237f665b376018ea5af0cc5f05814.tar.gz
iced-87b3e03d187237f665b376018ea5af0cc5f05814.tar.bz2
iced-87b3e03d187237f665b376018ea5af0cc5f05814.zip
Enable `instant` only for `wasm32` targets
... and hide the dependency under a `time` module in `iced_native`
Diffstat (limited to '')
-rw-r--r--native/Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/native/Cargo.toml b/native/Cargo.toml
index d8e75a4e..499ad29e 100644
--- a/native/Cargo.toml
+++ b/native/Cargo.toml
@@ -14,7 +14,6 @@ debug = []
twox-hash = { version = "1.5", default-features = false }
unicode-segmentation = "1.6"
num-traits = "0.2"
-instant = { version="0.1", features=["wasm-bindgen"] }
[dependencies.iced_core]
version = "0.4"
@@ -28,3 +27,7 @@ features = ["thread-pool"]
[dependencies.iced_style]
version = "0.3"
path = "../style"
+
+[target.'cfg(target_arch = "wasm32")'.dependencies.instant]
+version = "0.1"
+features = ["wasm-bindgen"]