summaryrefslogtreecommitdiffstats
path: root/graphics/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-03-03 03:55:07 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-03-03 03:55:07 +0100
commitbbeaf10c04a922af5c1c3b898f0c4301d23feab0 (patch)
treeb0d2b64d72ae29db324de7614b37af9c6ab68b54 /graphics/Cargo.toml
parent868f79d22e2be82e98b06d66da3b4cbc6139d7c7 (diff)
downloadiced-bbeaf10c04a922af5c1c3b898f0c4301d23feab0.tar.gz
iced-bbeaf10c04a922af5c1c3b898f0c4301d23feab0.tar.bz2
iced-bbeaf10c04a922af5c1c3b898f0c4301d23feab0.zip
Mark `Primitive` as `non-exhaustive` in `iced_graphics`
Diffstat (limited to 'graphics/Cargo.toml')
-rw-r--r--graphics/Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/graphics/Cargo.toml b/graphics/Cargo.toml
index 36d8a516..62e67cf8 100644
--- a/graphics/Cargo.toml
+++ b/graphics/Cargo.toml
@@ -34,7 +34,6 @@ log = "0.4"
raw-window-handle = "0.5"
thiserror = "1.0"
bitflags = "1.2"
-tiny-skia = "0.8"
[dependencies.bytemuck]
version = "1.4"
@@ -48,6 +47,10 @@ path = "../native"
version = "0.7"
path = "../style"
+[dependencies.tiny-skia]
+version = "0.8"
+optional = true
+
[dependencies.image_rs]
version = "0.24"
package = "image"