summaryrefslogtreecommitdiffstats
path: root/graphics/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar dtzxporter <dtzxporter@users.noreply.github.com>2023-09-12 18:15:00 -0400
committerLibravatar Héctor Ramón Jiménez <hector@hecrj.dev>2023-11-11 03:40:22 +0100
commit98e088e731e6fbd5b5035033ae61bda823ced988 (patch)
tree4e12f49f37ad6d5c6dffd06bc7fabc05930db3e1 /graphics/Cargo.toml
parent751ea77c29f6eb3d00f45f0a04c833a1d03a425c (diff)
downloadiced-98e088e731e6fbd5b5035033ae61bda823ced988.tar.gz
iced-98e088e731e6fbd5b5035033ae61bda823ced988.tar.bz2
iced-98e088e731e6fbd5b5035033ae61bda823ced988.zip
Migrate twox-hash -> xxhash_rust. Switch to Xxh3 for better performance.
xxhash-rust is more maintained, built against `::core`, so no workaround for wasm is necessary. Switch to Xxh3 for better performance, which shows when loading/hashing image buffers.
Diffstat (limited to 'graphics/Cargo.toml')
-rw-r--r--graphics/Cargo.toml6
1 files changed, 1 insertions, 5 deletions
diff --git a/graphics/Cargo.toml b/graphics/Cargo.toml
index 3165810b..a7aea352 100644
--- a/graphics/Cargo.toml
+++ b/graphics/Cargo.toml
@@ -33,8 +33,8 @@ once_cell.workspace = true
raw-window-handle.workspace = true
rustc-hash.workspace = true
thiserror.workspace = true
-twox-hash.workspace = true
unicode-segmentation.workspace = true
+xxhash-rust.workspace = true
image.workspace = true
image.optional = true
@@ -44,7 +44,3 @@ kamadak-exif.optional = true
lyon_path.workspace = true
lyon_path.optional = true
-
-[target.'cfg(not(target_arch = "wasm32"))'.dependencies]
-twox-hash.workspace = true
-twox-hash.features = ["std"]