summaryrefslogtreecommitdiffstats
path: root/graphics/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-03-01 21:34:26 +0100
committerLibravatar Héctor Ramón Jiménez <hector0193@gmail.com>2023-03-01 21:34:26 +0100
commit5fd5d1cdf8e5354788dc40729c4565ef377d3bba (patch)
tree0921efc7dc13a3050e03482147a791f85515f1f2 /graphics/Cargo.toml
parent3f6e28fa9b1b8d911f765c9efb5249a9e0c942d5 (diff)
downloadiced-5fd5d1cdf8e5354788dc40729c4565ef377d3bba.tar.gz
iced-5fd5d1cdf8e5354788dc40729c4565ef377d3bba.tar.bz2
iced-5fd5d1cdf8e5354788dc40729c4565ef377d3bba.zip
Implement `Canvas` support for `iced_tiny_skia`
Diffstat (limited to 'graphics/Cargo.toml')
-rw-r--r--graphics/Cargo.toml13
1 files changed, 2 insertions, 11 deletions
diff --git a/graphics/Cargo.toml b/graphics/Cargo.toml
index 9795d31f..36d8a516 100644
--- a/graphics/Cargo.toml
+++ b/graphics/Cargo.toml
@@ -24,8 +24,7 @@ bmp = ["image_rs/bmp"]
hdr = ["image_rs/hdr"]
dds = ["image_rs/dds"]
farbfeld = ["image_rs/farbfeld"]
-canvas = ["lyon"]
-qr_code = ["qrcode", "canvas"]
+canvas = ["iced_native/canvas"]
opengl = []
image_rs = ["kamadak-exif"]
@@ -35,6 +34,7 @@ log = "0.4"
raw-window-handle = "0.5"
thiserror = "1.0"
bitflags = "1.2"
+tiny-skia = "0.8"
[dependencies.bytemuck]
version = "1.4"
@@ -48,15 +48,6 @@ path = "../native"
version = "0.7"
path = "../style"
-[dependencies.lyon]
-version = "1.0"
-optional = true
-
-[dependencies.qrcode]
-version = "0.12"
-optional = true
-default-features = false
-
[dependencies.image_rs]
version = "0.24"
package = "image"